Суммирование в Excel через одну, две, три ячейки

Всем известен способ подсчёта данных в Excel путём элементарного сложения ячеек =C2+C4+C6, либо с помощью функции =СУММ(C2;C4;C6), но если таблица большая, то такой способ выведет из себя даже самого терпеливого. Поэтому предлагаю рассмотреть способ суммирования по условию: =СУММЕСЛИ(B2:B15;"Доход";C2:C15)=СРЗНАЧЕСЛИ(B2:B15;"План";C2:C15)
Суммирование в Excel через одну, две, три ячейки

Если же столбец с ключевым словом для выборочного суммирования отсутствует, то можно использовать формулу массива, которая будет проверять номер строки для каждой ячейки и суммировать только те из них, где номер четный.=СУММ(ЕСЛИ(ОСТАТ(СТРОКА(B2:B15);2)=0;B2:B15))=МИН(ЕСЛИ(ОСТАТ(СТРОКА(B2:B15);2)=0;B2:B15))=МАКС(ЕСЛИ(ОСТАТ(СТРОКА(B2:B15);2)=1;B2:B15))

Если же нужно суммировать каждую третью, четвертую и т.д. ячейки, то изменяется только делитель номера строки:=СУММ(ЕСЛИ(ОСТАТ(СТРОКА(C2:C17);4)=1;C2:C17))
В качестве второго варианта можно использовать функцию СУММПРОИЗВ, которая вводится как обычная формула (без Ctrl+Shift+Enter), но работает также:=СУММПРОИЗВ(--(ОСТАТ(СТРОКА(C2:C17);4)=1);C2:C17)

Для подсчёта суммы, находящейся в столбцах, вместо СТРОКА используем СТОЛБЕЦ, затем протягиваем формулу вниз:=СУММПРОИЗВ(--(ОСТАТ(СТОЛБЕЦ(B3:F3);2)=0);B3:F3)

Примечание: для красивого отображения цифр устанавливаем формат ячеек «Числовой» – Число десятичных знаков «0» – галочка на «Разделитель групп разрядов». Для процентов «Процентный» – Число десятичных знаков «0».
Опрос
БЫСТРО ЛИ ГРУЗИТСЯ САЙТ?