Суммирование в Excel через одну, две, три ячейки


Всем известен способ подсчёта данных в Excel путём элементарного сложения ячеек =C2+C4+C6, либо с помощью функции =СУММ(C2;C4;C6), но если таблица большая, то такой способ выведет из себя даже самого терпеливого. Поэтому предлагаю рассмотреть способ суммирования по условию: =СУММЕСЛИ(B2:B15;"Доход";C2:C15)=СРЗНАЧЕСЛИ(B2:B15;"План";C2:C15)
Суммирование в Excel через одну, две, три ячейки

Если же столбец с ключевым словом для выборочного суммирования отсутствует, то можно использовать формулу массива, которая будет проверять номер строки для каждой ячейки и суммировать только те из них, где номер четный.=СУММ(ЕСЛИ(ОСТАТ(СТРОКА(B2:B15);2)=0;B2:B15))=МИН(ЕСЛИ(ОСТАТ(СТРОКА(B2:B15);2)=0;B2:B15))=МАКС(ЕСЛИ(ОСТАТ(СТРОКА(B2:B15);2)=1;B2:B15))

Если же нужно суммировать каждую третью, четвертую и т.д. ячейки, то изменяется только делитель номера строки:=СУММ(ЕСЛИ(ОСТАТ(СТРОКА(C2:C17);4)=1;C2:C17))
В качестве второго варианта можно использовать функцию СУММПРОИЗВ, которая вводится как обычная формула (без Ctrl+Shift+Enter), но работает также:=СУММПРОИЗВ(--(ОСТАТ(СТРОКА(C2:C17);4)=1);C2:C17)

Для подсчёта суммы, находящейся в столбцах, вместо СТРОКА используем СТОЛБЕЦ, затем протягиваем формулу вниз:=СУММПРОИЗВ(--(ОСТАТ(СТОЛБЕЦ(B3:F3);2)=0);B3:F3)

Примечание: для красивого отображения цифр устанавливаем формат ячеек «Числовой» – Число десятичных знаков «0» – галочка на «Разделитель групп разрядов». Для процентов «Процентный» – Число десятичных знаков «0».




Добавить комментарий

Автору будет очень приятно узнать обратную связь о своей новости.

Похожие новости

Получение списка файлов в папке Получение списка файлов в папке
В Excel, путём проведения нехитрых махинаций, имеется возможность получения списка файлов, находящихся в папке компьютера. Для этого копируем путь к файлам в папке и вставляем его в нужную ячейку, при Автор: Veseliy.4el

Подсветка и сравнение двух и более списков Подсветка и сравнение двух и более списков
Автор: Veseliy.4el Некоторые пользователи не особо жалуют использование макросов в Excel, поэтому предлагаю рассмотреть сравнение двух списков с помощью условного форматирования и формул. Допустим, что у нас имеется два списка с повторяющимися

Как быстро "убить" компьютер Как быстро "убить" компьютер
Как быстро "убить" компьютер (программа будет работать пока не кончится ОЗУ, или-же цикл в БАТнике) Открываем блокнот, пишем: @echo (echo) off - Эта команда отключит вывод команд на экран :x - Метка, куда программа каждый раз будет возвращаться start

Как удалить баннер-вымогатель с рабочего стола Как удалить баннер-вымогатель с рабочего стола
Первый способ. 1. Нужно загрузить систему в безопасном режиме (нажимать F8 до загрузки системы, чтобы появились варианты загрузки, выбрать там "Безопасный режим"). 2. Когда система загрузилась, открываем редактор реестра. Чтобы открыть, нажимаем Win+R и

7 способов по-новому использовать Google Chrome 7 способов по-новому использовать Google Chrome
Одним из самых популярных браузеров в мире по праву считается Google Chrome. И это не удивительно, так как он достаточно прост в обращении и функционален. Но многие из пользователей Chrome и не подозревают о некоторых полезных командах, которыми можно

4 инструмента командной строки 4 инструмента командной строки
4 инструмента командной строки, о которых должен знать каждый пользователь Windows

101 комбинация на клавиатуре, которая может облегчить Вашу жизнь 101 комбинация на клавиатуре, которая может облегчить Вашу жизнь
101 комбинация на клавиатуре, которая может облегчить Вашу жизнь Если вы много работаете с компьютером, то вы знаете, что для быстрой и продуктивной работы нужно стараться обходиться без мыши. В этом выпуске Наука и Техника расскажет как более удобно

Яндекс.Браузер поддерживает поиск по странице с учетом морфологии русского языка Яндекс.Браузер поддерживает поиск по странице с учетом морфологии русского языка
Яндекс представил новую версию Яндекс.Браузера . В нем теперь реализован поиск по странице с учетом морфологии русского языка, появились жесты для управления навигацией в браузере; проводится эксперимент с объединением омнибокса и поисковой строки на

Что такое режим гибернации? Что такое режим гибернации?
Новые операционные системы Windows Vista и Windows 7 предлагают пользователям...